Verifiable Credential Sd Jwt
SD-JWT representation of a VerifiableCredential. According to "SD-JWT-based Verifiable Credentials (SD-JWT VC), Draft 03"
Constructors
Properties
OPTIONAL unless cryptographic Key Binding is to be supported, in which case it is REQUIRED. Contains the confirmation method identifying the proof of possession key as defined in RFC7800. It is RECOMMENDED that this contains a JWK as defined in Section 3.2 of RFC7800. For proof of cryptographic Key Binding, the Key Binding JWT in the presentation of the SD-JWT MUST be signed by the key identified in this claim.
OPTIONAL. The information on how to read the status of the Verifiable Credential. See (I-D.looker-oauth-jwt-cwt-status-list) for more information.
OPTIONAL. The expiry time of the Verifiable Credential after which the Verifiable Credential is no longer valid. See RFC7519 for more information.
OPTIONAL. The time of issuance of the Verifiable Credential. See RFC7519 for more information.
OPTIONAL. The time before which the Verifiable Credential MUST NOT be accepted before validating. See RFC7519 for more information.
REQUIRED. This specification defines the JWT claim vct (for verifiable credential type). The vct value MUST be a case-sensitive StringOrURI (see RFC7519) value serving as an identifier for the type of the SD-JWT VC. The vct value MUST be a Collision-Resistant Name as defined in Section 2 of RFC7515.